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Creating Maps using Canvas: Beginner's Guide 
 
1.0 Introduction 
 
The purpose of this guide is to help beginning digital cartographers lay out and draw cave maps 
electronically.  Many of the suggestions here are my personal preferences, including line weights 
and layer names, and can be changed to meet the needs or preferences of the cartographer.  The 
guide assumes that the user is at least generally familiar with the Windows operating 
environment, Windows-based programs, and the basics of cave mapping and cartography.  Some 
familiarity with drawing programs is helpful, but not necessary to use this guide.  This guide will 
not teach you all of the tools available in Canvas.  Use the on-line help and manuals to find tricks 
and shortcuts for some of the more common tasks. 
 
1.1 Why Digital? 
 
Digital cartography increases the flexibility of cave maps.  Updating and adding new passages to 
digital maps is relatively easy and faster than with convention pen-and-ink maps.  Digital maps 
are easier to scale for multiple purposes (wall maps vs. publication maps) and are much easier to 
integrate into GIS, web sites, digital documents and other forms of electronic publishing. 
Photographs and color geology can easily be added to digital maps to present more information 
than conventional maps. In general, digital cave maps are more dynamic and adaptable than 
other types of maps. 
 
1.2 Drawing vs. CAD Programs 
 
There has been a great deal of debate about what kind of programs work best for drafting cave 
maps.  CAD systems (AutoCAD, IntelliCAD, Microstation) are great for maintaining real-world 
coordinate systems and are easily integrated into GIS.  Drawing programs (Canvas, Illustrator, 
CorelDraw) contain more freehand and image editing tools.  However, the biggest advantage 
drawing programs have over the CAD programs is their shorter learning curve.  Traditional 
cartographers can learn to use drawing programs much faster than trying to learn the specialized 
lingo and skills of technical drawing. 
 
2.0 Getting started 
 
Start Canvas using the start menu.  A new drawing will automatically appear in the window.  If 
you want to continue work on an existing drawing select Open from the File menu.   A dialog 
box will appear so you can select a file.  If you make a mistake in a drawing and want to start 
over, select New from the File menu.  A selection box will appear with several drawing options, 
illustration, publication, or presentation.  Select the Illustration option for doing cave maps.    
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2.1 The menus and toolbars  
 
The top of the work area contains three parts, the menu bar, the toolbar and the docking bar 
(figure 1).  The menu bar is a set of pulldown menus with commands and tools. The Toolbar 
contains buttons you can click to choose commands, tools, inks, strokes, and styles. To display 
the Toolbar: select Window > Palettes > Show Toolbar. To hide the Toolbar: select Window > 
Palettes > Hide Toolbar.  The docking bar allows you to keep palettes such as the document 
setup palette, and macro box "docked" at the top of the screen, so you don't have to go through 
the pulldowns or Tool Box to get to your most-used features. 
 

Figure 1. The Canvas work area 
 
2.2 Document set-up and layout 
 
To set up the blank page, go to the Layout menu and select Document Setup.  A dialog box will 
appear that gives you the options for setting up the drawing environment.  You can choose any 
standard paper size by selecting it in the illustration size pulldown menu.  You can also define 
your own map size using the custom option in the illustration size pulldown menu and then 
typing in the dimensions manually.  These settings can be changed later without affecting your 
drawings if you decide you need more or less space later. 
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2.3 Suggested layers  
 
It is best to keep different types of information on different layers.  This helps to avoid cluttering 
the screen with too much information during drawing and it helps to create different types of 
maps later on. To create, delete, or modify layers go to the Layout menu and select Document 
Layout.  The document layout palette (Figure 2) will then appear. Click the + sign next to the 
text that says Page 1 and the list of layers will appear. Click on the layer name (Layer 1 is the 
only layer in a new drawing) and then click the New Layer button at the bottom of the document 
layout box.  To change the name and other parameters of a layer, double-click the layer name.  
Below is a table of layer names that I use and what they contain: 
 

 
Figure 2. Document layout palette 
 
Name  Contains 
Walls  passage walls, bedrock pillars 
Structural  symbols representing changes in ceiling height, 

slopes, pits, domes, dropoffs, etc. 
Detail  floor detail such as sand, mud, bedrock, 

stalactites, stalagmites, breakdown, etc. 
Cross-sections and ceiling heights  ceiling height circles and passage sections 
Elevations  passage elevations 
Stations  survey station symbols and station labels 
Text  passage labels and other text items 
Scale  scale bar and north arrow 
Bitmap  the scanned and assembled bitmap of the cave 

or cave passage 
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In general, it's best to keep the bitmap as the bottommost layer since everything will be drawn 
over the bitmap.  The order of the other layers is not as important and can be customized to your 
needs. 
 
2.4 Creating bitmaps 
 
In order to create a digital cave map, you will need an original pencil drawing of the map or 
passage first.  You can either scan in the pencil version of the map or digitize it directly from a 
digitizing tablet.  The following procedures are for scanning and digitizing on-screen using the 
mouse. 
 
If you are dealing with a small cave that fits on only one or two survey pages, you can just scan 
the original notes into the computer.  For a longer cave, I suggest drafting the pencil version of 
the map on gridded paper first and then scanning in the pencil map.  It is possible to assemble 
larger cave maps using scans of original notes, but that requires importing the line plot into the 
computer and a lot of manipulation of the notes that is currently easier by hand.  It is 
recommended that you draft on gridded paper (mylar, velum, etc.) so that you can reassemble the 
map from the scanned pieces. 
 
Each scan will result in a bitmap image to be saved on disk.  I generally use either the TIF or 
JPEG file formats since they give the best quality for the smallest file sizes.  These bitmaps will 
be reassembled in Canvas later. 
  
2.5 Assembling bitmaps 
 
Unless you have a map scanner, you will probably have to scan your pencil map into the 
computer in smaller pieces.  If possible, try and keep the page straight in the scanner.  This will 
speed up the process of assembling the map in the computer.  Otherwise you may have to rotate 
the bitmaps so that north is the same direction on each one. 
 
Go to the Layout menu and select Document Layout.  The document layout palette (Figure 2) 
will then appear.  Click on the layer named Bitmap to make it the active layer.  Click on the 
drawing space to make it active and then select Place from the File menu.  A document dialog 
box will appear.  Choose the format you want to input and then the first bitmap image of your 
pencil drawing.  Make sure that the option to "Place on Current Layer" is checked.  An angular 
cursor will appear on the screen that will allow you to place the bitmap.  Click on the drawing 
and Canvas will import the bitmap.  Repeat these steps for every bitmap you have scanned in. 
 
Using the gridlines on the scans, move the bitmaps back together.  You may have to rotate the 
bitmaps slightly to make them fit.  Go to the Effects menu and select Rotate.  In the rotate 
dialog box, you can type in the exact angle of rotation.  It may take several tries to get the correct 
rotation.  When you have assembled all of the bitmaps together, select them all by dragging a 
box around them with the cursor.  You may have to zoom out using the magnifying button on the 
toolbox to see all of the bitmaps.  After they have all been selected, go to the Object menu and 
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select Group.  This will make all of the bitmaps into one object that you can move around the 
space.  This will also prevent you from inadvertently disassembling the bitmaps as you work. 
 
2.6 Setting up the map 
 
Try to center the assembled bitmaps on the page.  You may have to go back and change the page 
dimensions using the page set-up procedures described above.  Leave enough room to put in 
passage names, ceiling heights, elevations, etc.  You are now ready to begin drawing the cave 
map. 
 
3.0 Drawing the Cave (Plan View) 
 

 
3.1 Walls 
It does not matter what order you digitize the map features in, but it is best to only work with one 
layer at a time.  I generally do the walls first, then the structural features, and then the floor 
detail. Go to the Layout menu and select Document Layout.  The document layout palette 
(Figure 2) will then appear.  Click on the layer named Walls to make it the active layer.  On the 
toolbox, make sure that the fill is set to no fill, the line color is set to black and that the line 
weight is set to 1.5. 
 

 
Curve Tool 

 
Select the curve tool shown above and begin tracing the walls.  Each left mouse click you make 
will add a point to the line.  Double-click a point to end the line.  If you accidentally close the 
line and didn't mean to, just double-click the line, select the curve tool, and keep drawing. 
 
3.2 Structural 
 
Go to the Layout menu and select Document Layout.  The document layout palette (Figure 2) 
will then appear.  Click on the layer named Structural to make it the active layer.  On the 
toolbox, make sure that the fill is set to no fill, the line color is set to black and that the line 
weight is set to 1.0. 
 

Line Tool 
 

Line Weights 
 
1.5  Walls, including bedrock ceilings in the profile and cross-sections 
1.0  Structural details and floors in the profile and cross-sections 
0.5  Floor detail on plan, profile, and cross-sections 
 
I also use rounded corners and ends for all of the lines 
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For some of the structural detail (such as floor drops, domes, pits, etc.), use the curve tool to 
draw the overall shape and the line tool to make the hatchures.  For changes in ceiling height, 
you can draw a dashed line and then add the hatchures using the line tool. 
 
3.3 Details 
 
Go to the Layout menu and select Document Layout.  The document layout palette (Figure 2) 
will then appear.  Click on the layer named Details to make it the active layer.  On the toolbox, 
make sure that the fill is set to no fill, the line color is set to black and that the line weight is set 
to 0.5. 
 
For symbols such as breakdown and flowstone, use the curve tool.  For standard symbols, you 
may want to use some built-in symbols which Canvas calls macros.  The macros can be found on 
the toolbox (figure 3) as the symbol that looks like shelved books. 

Figure 3. Macro Tool in toolbox 
 
In order to set up the macros for the first time, drag the symbol into the work area as shown in 
figure 4.  In the lower right corner, select the arrow and Canvas will display several options.  To 
load an existing set of symbols, select Append Set and Canvas will display a file dialog box and 
you can select the palette that contains the symbols.  Canvas 5 uses a *.pal extension and version 
6 and 7 use a *.mcr extension. 
 
The symbols appear in the macro box.  To use them, just click on the symbol you want and then 
click on the part of the map where you want it.  To place the same symbol many times, make 
sure you have "retain selected tool" selected in your Preferences under the File pulldown menu. 
If "Retain selected tool is selected, every time you click the left mouse button, the selected 
symbol will appear. 
 
If you want to create your own symbol, draw it using the drawing tools, group all of the parts of 
the new symbol together, and then drag it into the macro box.  Remember, if you want to make 
your new symbol part of the master symbol set, you will need to click on the arrow on the lower 
right of the macro box and choose "Save Set."  
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3.3 Cross-sections and ceiling heights 
 
Drawing the cross-sections is the same as drawing other parts of the map except you use 
different line weights on the same layer.  I use 1.5-point lines for the bedrock ceiling, 1.0-point 
lines for continuous floor, and 0.5-point lines for the floor detail (figure 5).  I also add floor 
detail to the sections using macros. After I have drawn the cross-section, I group all of the parts 
of the section together into one object to make it easier to arrange the pieces in the final drawing. 

 
Text Tool Circle Tool 
 

Use the Text tool to place the ceiling heights on the cave map.  Then use the Circle tool to draw 
the circle around the text.  If you hold down the shift key while sizing the circle, Canvas will 
draw a perfect circle and not an ellipse.  Once you have the text and circle drawn and centered on 
each other, group them into one object and place where you want it. 
 
3.4 Text 
 
Use the Text tool to place the text on your cave map.  I usually use an Arial font for text that is 
part of the map, because it is easier to read than most of the other fonts.  Be sure to include the 
entrance, name of the cave and general location (state, county), the dates of survey, the list of 
mappers, your name and copyright notice, and other details such as cave length and depth. 

 
4.0 Drawing the Cave (Profile View) 
 
Use the curve tool and macros to draw the profile.  If you are drawing the profile in the same 
space as the plan view.  Put the bedrock features (ceiling, etc.) on the Walls layer and put the 
other information on the Details layer.  I use the same pen weighting scheme as I do for the 
cross-sections.  Put any text you want on the profile onto the Text layer. 
 
5.0 Assembling the Final Map 
  
5.1 Technical details 
 
For the final map, you will need to add a north arrow and scalebars for both the plan view and 
the profile.  You will also need to create an explanation for all of the symbols you have used on 
your map.  I find it easiest to make a master explanation on a separate drawing with all of the 
common cave symbols.  I then place a copy of the explanation into my current map and remove 
all of the symbols that I didn't use. 
  
5.2 Moving things around 
 
Once you have all of the pieces of your map in the drawing area, you will probably want to 
rearrange things to make the layout look better to win Medal at the annual NSS Cartographic 
Salon.  Moving things is fairly easy, but you have to be careful about how you group objects to 
move them.  There are two basic ways of moving things around without messing up your map. 
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On the File pulldown menu, select Preferences and check the box that reads "Select Across 
Visible Layers."  With this box checked, you can select the whole plan map and then move it.  At 
this point, you have to be very careful about how you grab the selected objects with the mouse.  
If you click wrong, you will move only one piece of the map and will have to madly scramble up 
to the undo button.  Another way is to group the plan (or profile) together before moving it. 
 
First, on the plan map, select all of the items on the Walls layer and group them together.  Repeat 
this with all of the layers on your plan map.  Now repeat this process on all of the layers of your 
profile map.  Doing this will allow you to put your drawing objects back on the right layers later.   
 
Make sure you have "Select Across Visible Layers" checked in you preferences.  Now you can 
group all of your grouped layers together on the plan map (or profile).  Keep in mind, that when 
you do this, all of the groups will be brought to the active layer.  Now select all of your grouped 
layers by dragging a selection box around them.  Group these together and now your plan map is 
one object that you can move around.  Repeat the process for your profile map.  Shift stuff 
around and win that medal. 


